Ultima modifica: 17 Novembre 2019
Home > In primo piano > Versione Beta-PASW2015 per php7 e plugins
Ultima modifica: 17 Novembre 2019

Versione Beta-PASW2015 per php7 e plugins

Correzioni ai file del tema PASW 2015 e dei plugins per essere compatibili con versione dell’interprete PHP 7

Versione 2015.1.9BETA di PASW2015 (di Marco Milesi) compatile con la versione php 7.XX di hosting con le stringhe di codice del file incluso in  pasw2015/include/widget.php già corrette.
Basta scompattare e trasferire via ftp

frecciaPASW 2015 1.9 BETAC compatibile con versione WordPress 5.3

Tema con correzione al file wp-dependency-installer

pasw2015
Titolo: pasw2015 (0 click)
Filename: pasw2015.zip
Dimensione: 1 MB

 

Il passaggio a php7 evidenzia un problema nei plugin AVCP e AMMINISTRAZIONE APERTA (di Marco Milesi)

Per semplificare la procedura in allegato i plugins già  modificati

frecciaPlugin AVCP

Occorre aggiungere gli apici alle righe di codice nel file contenuto in wp-content/plugins/avcp/tablegen.php alla riga 23

riga 23

da query_posts( array( ‘post_type’ => ‘avcp’, ‘orderby’ => date, ‘order’ => DESC, ‘posts_per_page’ => -1, ‘annirif’ => $anno) );

a query_posts( array( ‘post_type’ => ‘avcp’, ‘orderby’ => ‘date’, ‘order’ => ‘DESC’, ‘posts_per_page’ => -1, ‘annirif’ => $anno) );

*nella versione 6.7.2 gli apici mancano solo a DESC

Anac-riga-23

 

 

 

 

avcp
Titolo: avcp (0 click)
Filename: avcp.zip
Dimensione: 658 KB

 

frecciaPlugin Amministrazione Aperta

Occorre,come sopra, aggiungere gli apici alle righe di codice nel file contenuto in wp-content/plugins/amministrazione-aperta/tablegen.php

riga 80
da query_posts( array( ‘post_type’ => $tipo, ‘orderby’ => date, ‘order’ => DESC, ‘posts_per_page’ => -1 ) );
a query_posts( array( ‘post_type’ => $tipo, ‘orderby’ => ‘date’, ‘order’ => ‘DESC’, ‘posts_per_page’ => -1 ) );

Amm-aperta-riga80

amministrazione-aperta
Titolo: amministrazione-aperta (0 click)
Filename: amministrazione-aperta.zip
Dimensione: 411 KB

 

7 commenti »

  1. Alberto ha detto:

    buongiorno a a tuuti
    ho visto che l’ultima release dio WordPress mette come
    “obbligatorio” il php7
    secondo voi uscirà anche un aggiornamento ” ufficiale” al passw2015 ?

    nel caso entro quanto tempo ?

    lo chiedo come potete immaginare per tranquillizzare gli operatori che sospettano di un essere completamente a posto

    grazie

  2. rb ha detto:

    Io ho installato l’ultima versione del tema e i problemi di compatibilità con php 7 relativi a github-updater continuano ad esserci. Devo reinstallare questa nuova versione di pasw2015? Oppure devo fare altro?

  3. Alberto ha detto:

    si è risolto ( forse per un problema di cache sul browser continuavo a vederlo anche con la patch apportata al php in questione)

  4. Fabio ha detto:

    Buongiorno a tutti, problema migrazione da .gov.it (hosting linux) a .edu.it (hosting wordpress gestito): sul .gov ho wp 5.1.3 e php 5.6 e funziona tutto, sul .edu è tutto aggiornato alla ultima versione e quindi facendo la migrazione il tema paws 2015 ha tanti problemi. Fare un downgrade sul .edu non si può, mi consigliate di provare la beta di paws?

  5. Caterina ha detto:

    Ciao Fabio sì devi sostituire la versione di Pasw2015 con quella beta condivisa nell’articolo e compatibile con gli ultimi aggiornamenti.
    Se con l’upgrade di WordPress a 5.3 riscontrassi warning seguir le indicazioni pubbliacate a questo link
    Buon lavoro

  6. Fabio ha detto:

    Ok grazie. Quindi, ricapitolando, aggiorno alla beta, aggiorno il php alla 7.x, aggiorno wordpress alla 5.3 e migro il tutto sul nuovo dominio?

Lascia un commento

 




Link vai su