Ultima modifica: 17 Novembre 2019
Home > CMS > Aggiornamento a WordPress 5.3
Ultima modifica: 17 Novembre 2019

Aggiornamento a WordPress 5.3

Risolvere warning generato dall’upgrade!

Aggiornando wp alla versione 5.3 può capitare di ricevere un warning, questo:

Warning: Declaration of WPDI_Plugin_Installer_Skin::feedback($string) should be compatible with WP_Upgrader_Skin::feedback($string, …$args) in directory nome della scuola/wp-content/themes/pasw2015/include/wp-dependency-installer.php on line 490″

Per risolvere editare il suddetto file e modificare alla riga 494

*Apri il file con un buon editor di testo o strumento per sviluppatori (Notepad++, Atom)

Percorso-include

 

 

File-da-correggere

Scrolla fino  alla riga 490

/**

* Class WPDI_Plugin_Installer_Skin

*/

class WPDI_Plugin_Installer_Skin extends Plugin_Installer_Skin {

public function header() {}

public function footer() {}

public function error( $errors ) {}

public function feedback( $string ) {}

Riga494-da-modificare

e modifica in questo modo la riga 494

/**

* Class WPDI_Plugin_Installer_Skin

*/

class WPDI_Plugin_Installer_Skin extends Plugin_Installer_Skin {

public function header() {}

public function footer() {}

public function error( $errors ) {}

public function feedback( $string, …$args ) {}

Riga494-modificata

in pratica all’ultima riga dopo $string aggiungere una virgola e …$args

2 commenti »

  1. Alberto ha detto:

    nel mio caso dopo aver aggiornato la riga con
    public function feedback( $string, …$args ) {}

    ho ancora il warning solo in home page
    Warning: Declaration of WPDI_Plugin_Installer_Skin::feedback($string) should be compatible with WP_Upgrader_Skin::feedback($string, …$args) in /web/htdocs/www.cpiaforlicesena.edu.it/home/wp-content/themes/pasw2015/include/wp-dependency-installer.php on line 490

    cosa potrei fare ?
    grazie

Lascia un commento

 




Link vai su